iZettle E-commerce

Description

Connect your iZettle account to your WordPress site and turn it into a fully functioning ecommerce store with synchronised inventory. Add your whole store, product widgets and Buy Now buttons to your WordPress site with our free plugin. Comes with an optional navbar shopping cart to offer your customers multiple product purchases. Customers check out on your site and are not diverted.

  • Directly connected with your existing iZettle account
  • Process all major credit cards and PayPal
  • Synchronised inventory
  • Optional multi-purchase navbar shopping cart
  • Free SSL certificate

Requirements

An iZettle Go+ account

Key Features

  • Synchronised to your iZettle account and inventory
  • Customers checkout on your site
  • Optional fully featured shopping cart permanently available to the customer with multiple items
  • Add buy buttons, product widgets or a whole store to your WordPress site with no coding

Installation

Install the plugin automatically from your WordPress dashboard or download it as a Zip file and install it manually.

Automatic Installation

  1. Install directly from your Dashboard (Plugins > Add New). Just search for “izettle e-commerce”.

Manual Installation

  1. Download the plugin zip file to your computer
  2. Navigate to to the ‘Plugins’ page in the WordPress Dashboard
  3. Select ‘Add New > Upload > Choose File’ and select the ‘izettle-ecommerce.zip’ file

Once the plugin has been activated you will see the new Gutenberg blocks available under ‘iZettle Ecommerce’.

FAQ

Does this plugin work with all themes?

Yes, the plugin works with any theme. The store, product widget and buy now buttons are all fully customisable too to match your brand.

I have more questions, who do I contact?

If you have queries, you can contact us here at help@izettle.com

Reviews

May 27, 2019
Added over 500 products from the webshop to iZettle on my iPad, made all the sales on the event so easy, with thumbnails, search, prices and much more up to date! Really great integration! Full version is not cheap.
December 17, 2018
Izettle want us to to remove woocommerce because they want us to use izettle shopping cart insted. All i wanted with this plugin was a payment gateway like stripe or paypal. This plugin Need to Be Re-written. A lot of work remains.
November 25, 2018
So, you want us to pay you to create another eCommerce store when we already have a working eCommerce store using WooCommerce? At least show us some dignity by doing some research before releasing such plugins to us. You should know all your users on WordPress would already have WooCommerce stores. I reckon you need to go back to the drawing board and figure out all we need is a payment gateway that is linked to the iZettle card reader! Just like PayPal Here. Create a gateway for WooCommerce that will allow us to collect payment via our card readers when iZettle/POS is selected as medium of payment. Absolute joke. iSettle not for such iZettle!
Read all 2 reviews

Contributors & Developers

“iZettle E-commerce” is open source software. The following people have contributed to this plugin.

Contributors

“iZettle E-commerce” has been translated into 1 locale. Thank you to the translators for their contributions.

Translate “iZettle E-commerce” into your language.

Interested in development?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Changelog

2.1.1

  • Minor bug fix preventing plugin conflicts

2.1.0

  • Added: New category panel for the store block
  • Added: Automatic creation of store page on connection
  • Added: Toolbar menu for easy navigation to store pages
  • Added: UI improvements for new users

2.0.1

  • Added: Backward compatibility for shortcodes. Previously, shortcodes weren’t rendering on the front-end.

2.0.0

  • Fully compatible with WordPress 5.0; embeds are now fully featured Gutenberg blocks. Please note: if you previously installed the “Classic Editor” plugin, you’ll need to deactivate upon upgrading.

1.0.4

  • Fixed a compatibility issue with WordPress 5.0. Please note: to use this plugin with WordPress 5.0, the “Classic Editor” plugin is required. Full support for 5.0 and the new Gutenburg editor is coming soon.

1.0.3

  • Minor UI bug fix

1.0.2

  • Bug fixes with OAuth and API integration

1.0.1

  • An improvement to make updating more obvious

1.0.0

  • Initial release